Kilo Cloud platform is not accessible.

Incident Report for Kilo

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2026 - 13:54 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 12, 2026 - 13:32 UTC

Identified

We continue to work on resolving the current outage affecting the Kilo Cloud platform.
Posted Aug 12, 2026 - 13:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2026 - 13:26 UTC

Identified

We are actively working on resolving the current incident affecting the Kilo Cloud platform.
Posted Aug 12, 2026 - 13:09 UTC
This incident affects: Kilo Cloud Platform (app.kilo.ai).