Usage page is not showing any data for users.

Incident Report for Kilo

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 14:37 UTC

Identified

We are aware of the issue and are working on a resolution.
Posted Aug 12, 2026 - 12:07 UTC
This incident affected: Kilo Cloud Platform (app.kilo.ai).